Secrets Hub outage - us-east-1 region

Incident Report for Secrets Hub

Resolved

The issue has now been resolved, and the service is fully recovered.
For detailed status history, please visit the AWS Service Health Dashboard: https://health.aws.amazon.com/health/status
Thank you for your patience
Posted Oct 20, 2025 - 20:00 UTC

Identified

We are currently experiencing an unexpected outage in the US East (us-east-1) region affecting the Secrets Hub service.
The root cause is an infrastructure outage within Amazon Web Services.
During this incident, you may experience service unavailability or degraded performance.
For real-time status updates, please visit the AWS Service Health Dashboard: https://health.aws.amazon.com/health/status
Thank you for your patience
We will keep you updated as we learn more.
Posted Oct 20, 2025 - 18:00 UTC
This incident affected: North Virginia (us-east-1).